
Duplicating optical discs using ISO-Buster
Disclaimer: This  document  is  provided  only  as  a  convenience.  You  use  it  and/or  follow  the 
instructions in it at your own risk. Neither I nor the author of ISO-Buster will be responsible for 
anything that occurs as a result of using and/or following the instructions in this document.

Note: This is not a replacement for the ISO-Buster documentation. It speaks only of a very particular 
topic. Do not look for general ISO-Buster howto-s here.

Warning: The duplication of a disc may be illegal – you proceed under your own (juris)prudence.
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Introduction

All right, now that we’ve got those harsh things out of the way, let’s come to the nice useful part.

(In case you want to skip all the introduction to disc-copying, feel free to jump to the topic Creating
disc images using ISO-Buster on page 2.)

Ever tried to copy a disc, only to find that it doesn’t have the same functionality as the original? You 
may have experienced this with bootable computerdiscs, audio discs, and possibly other kinds of 
discs too.

The reason why you would have experienced this  is  probably that you thought that copying an 
optical disc meant copy&paste, like on a hard disk.

Well that’s what isn’t true.

Why disc-copy is not just copy&paste

We will not go into too many technical details here (since I don’t profess to know all of them and 
since they aren’t necessary) but an optical disc contains much more than just files. For audio discs, 
the disc contains information on where each music track ends and the next begins, and for bootable 
discs, the disc contains the boot-image, which has the instructions that a computer needs for booting 
from that disc. This is just for starters.

All this stuff is not exactly stored in the form of files as we understand it. Which is why we can’t 
simply copy the files on an optical disc to a computer, write them to a blank disc and expect the new 
disc to work the same way as the old one.

Disc-burner programs and the disc-copy function

That’s why all good disc burner programs come with a disc-copy function, which copies the  entire 
contents of the discs, both files and non-files, as it is, thus rendering a proper duplicate of the original 
disc.

That’s all good and fine, but the problem comes in when the original disc is not in good shape – 
perhaps it is scratched. In this case, your disc burner program might simply leave you stranded with 
an error message “Unable to create image” or something like that.



Two kinds of disc-copy

But note something here: there are two ways you can use your burner’s disc-copy function. One is 
what is called ‘on-the-fly’ copying. This means reading the data from the source disc and writing it to 
the target disc simultaneously.

Of course, this is possible only when you have two optical disc drives. If you have only one drive, you 
are forced to use the other way of copying, which is to create an image of the original disc on your 
hard disk, remove the source disc from your optical drive, insert the target disc, and then write the 
image from the hard disk to the target disc.

Why avoiding ‘on-the-fly’ disc-copy is better

Actually, this second method is preferable even if you have two optical drives. The reason? Well, what 
happens if your source disc is not in good condition, as said above? You would have probably written 
your target disc half-way through, and then suddenly your burner says “Sorry but I can’t read the 
source disc – this disc-copy will be aborted”? Your target disc might well be rendered useless, and 
you may not be able to redo the copy properly once more, or even read the data you have already 
written. Of course, none of us wants to waste a disc (however cheap) like that. Which is why unless 
we’re sure that both the source and target discs are in top condition we won’t do an ‘on-the-fly’ disc-
copy.

Why you need ISO-Buster to copy a problematic disc

All right, now it stands recommended that using the slower method of copying the source disc image 
to your hard disk and then writing it to the target is the safer method of duplicating a disc, especially 
when your source disc is potentially damaged.

Usually, your burner program will do this for you, as said before, but it will probably abort upon 
encountering  a  small  read  error,  since  it’s  designed  for  burning  to discs,  not  reading  from discs, 
especially problematic discs.

This  is  where  ISO-Buster  (http://www.isobuster.com)  steps  in.  ISO-Buster  is  probably  the  best 
program to read stuff from optical discs – it does not get daunted by minor errors, and instead does 
all sorts of neat tricks to coax the data out of your unyielding source disc. Often, ISO-Buster will 
succeed where other attempts at recovering the data from your discs will fail.

And ISO-Buster also has a great image creation function which is what we will be using here.

Creating disc images using ISO-Buster

The procedure to create a disc-image using ISO-Buster is pretty straightforward. 

1. Load your source disc into your drive and startup ISO-Buster. It should read the contents of 
the disc (the entire content, not just the files) and display a tree view on the left pane. In case 
you do not get any such display, make sure that you have selected the right optical drive in 
the drop-down box below the menu.

2. Now goto  the  menu –  Options >  Image Files.  Under “Select  when a  cuesheet  file  will  be 
created”, make sure that either “Always after a CD or DVD image is created” or “Prompt after 
a CD or DVD image is created” is selected. It is better to select “Always”.

http://www.isobuster.com/


3. Optionally, you may also select “Always” or “Prompt” under “Select when an MD5 checksum 
file will be created”. We will explain this part later.

4. Click OK to exit the dialog.

5. On the left-hand pane of the main window, you will see a tree structure. At the top(-left) of 
this tree, you will see a small disc icon and CD or DVD-R or something similar based on what 
kind of medium you have inserted into the drive. Right-click on this.

6. You will see a menu popup. If the disc is a CD, select Extract CD (Image) > RAW (*.bin, *.iso). If 
it is a DVD, select Extract DVD (Image) > User Data (*.tao, *.iso).

7. You will see an  Extract File dialog asking for a location and filename for the image file you 
want to create. Navigate to where you want the image file to be saved. 

1. Make sure this location has sufficient free space, since image files, especially DVD image 
files, can be huge, running into several gigabytes. 

2. Note that files larger than 4 GB cannot be stored on FAT32 partitions, so if your source 
disc contains 4 GB or more data, then you should save the image to an NTFS partition. 
(Partitions are portions of your hard disk, shown as drives  C,  D etc in Windows. To find 
out what kind of  partition a particular “drive” is,  open  My Computer under  Windows 
Explorer, go to the menu item View > Details. If you do not see the File System column, 
then enable its display under View > Select Details.

8. Now enter a filename with the extension .iso and press Save.

9. ISO-Buster should (successfully) extract your disc data and write it to the image file on your 
hard disk.

10. In case you selected “Prompt” under “Select when a cuesheet file will be created” back in step 
2, then you will be prompted for a location to create what is called a cuesheet file. Save this 
with the extension .cue, preferably with the very same name in the very same location where 
you saved the .iso file.  Do NOT skip creation of the cuesheet file! You will probably end up 
burning a useless disc. The cuesheet file contains internal information about the disc which is 
very important for proper burning later. This is why it is better to select “Always” in step 2, 
since it will make ISO-Buster automatically create the .cue file for you.

11. In  case  you selected  “Prompt”  under  step  3  above  as  well,  you  will  be  now  asked  for  a 
filename and location for what is  called the MD5 checksum file.   The MD5 checksum file 
contains what is called an MD5 hash, for both the image file and its cuesheet file. This hash is 
a sort of distilled essence of your files, and it will tell you at a later time whether your files are 
in proper condition or have been corrupted. For more details, see the appendix. For now, just 
give the same name and location as for the .iso and .cue files, but use the extension .md5. ISO-
Buster will create the MD5 hash for your .iso and .cue files.

12. Now you have what you need to create an exact duplicate of your original disc!

A few warnings:

1. It is better to keep your .iso file and .cue file (and .md5 file) in the same directory, always.

2. If by error you write the .iso and .cue files to different directories, move them to a single 
location.  ISO-Buster  has  the  sense  to  ask  you  “where  is  the  .iso  file?”  but  your  burning 
program may not and then throw some error at you, or worse, create a bad disc.



Burning the created image to the target disc

Now that you have created the image files, you are all set to burn your target disc. You may close 
down ISO-Buster now, and fire up your favourite burning program. You should have an option called 
Burn Image to Disc. Sometimes you have a separate such menu item for CD images and for DVD 
images. Make sure you select the correct one.
Do NOT choose the Create Data Disc option in your burner. This will only create an .iso file on your 
disc, which is useless to you, since you wanted to recreate the source disc on your target disc and not 
store its image. There’s a big difference. Burn Image to Disc will understand that your image file is an 
image file, and reproduce the disc of which this file is an image, but Create Data Disc will think that 
your image file is just another data file and store it to your target disc as another data file – which is 
useless to you.
Now when you are asked for the location of the image file to burn to disc, give your burner program 
the position and filename of the CUESHEET file. Do NOT give it the filename of the .iso file! This may 
result  in  a  defective  write  in  some cases.  The  cuesheet  itself  will  tell  the  burning  program the 
location of the .iso file (unless you have changed the position of the .iso file since you first created it 
– remember the warning on the previous page).
Make sure than an appropriate writable medium is placed into your optical disc writer, and go ahead 
with the burning! Good luck!

General safety tips for when writing a disc

1. It is usually safer to write a disc at a lower speed. This avoids write errors.
2. Avoid running other applications, especially resource-hungry ones (like graphics handling, 

some word processing programs etc). Disc burning is a sensitive process – you don't want to 
muddle it up.

3. Make sure your computer is receiving power backup from the UPS (or if you don't have a UPS 
then just  pray that power won't go off  during the writing).  It  is  not possible to continue 
writing a disc after power goes off in the middle.

4. Even if you have a UPS, make sure your burning process will be done well within the backup 
time provided by the UPS.

5. If your system goes on UPS, or is on a weak voltage-stabilizer, and your monitor switches off 
(due to your power saving settings) during the burn do NOT switch on the monitor again until 
your writer drive light goes off (indicating end of burning). Monitors (especially the regular 
CRT ones) draw a lot of power suddenly, when switched on, and your UPS or voltage stabilizer 
may not be able to handle this, causing your system to be reset and your writing operation to 
be disrupt. Of course, this applies for any other operation…

Feedback

This document was created by Shriramana Sharma (jamadagni at gmail  dot com) on 2005-09-01. 
Please send me your constructive feedback at the above mail address.
In case you are interested, my website at http://samvit.org. Do visit.

http://samvit.org/


Appendix

Verifying the integrity of files using MD5 checksums

As we mentioned before, an MD5 checksum of a file is a sort of distilled essence of that file. It is 
always a sequence of 32 characters, which may each be any of 0 to 9 or a to f. The following two are 
examples of such checksums:

0cc175b9c0f1b6a831c399e269772661                7215ee9c7d9dc229d2921a40e899ec5f
The first is from a single-byte file with only the single letter “a” (without the quotes of course). The 
second is from a similar file  with a space replacing the letter “a”.  As you see,  even the smallest 
change in the file will cause a (big) change in the checksum. This allows us to detect whether a file 
has been modified or not. Generally speaking, it is impossible to find two different files that have the 
same checksum – a checksum is calculated that way. That assures you that even the smallest change 
or error in the source file will be detected and reflected in the checksum.
Now since ISO-Buster allows you to create checksums (see steps 3 and 11 in the writing procedure 
above), you also have the privilege of knowing whether an image file you have written to your hard 
disk (perhaps long ago) is in a safe condition, whether it has not been damaged by viruses or freak 
corruption. A corrupted image file can potentially result in a defective write. So it's always wise to 
save the MD5 checksum back in steps 3 and 11, so that you can check the integrity of your file using 
ISO-Buster itself or an independent MD5 hash calculation program.

Calculating the MD5 checksum of an image using ISO-Buster

ISO-Buster also has the ability to open an image file that you have saved to your hard disk. Just go to 
the menu File > Open Image File and specify the location and filename of your cuesheet file. Again, do 
NOT give it the path of your .iso file. 
Now ISO-Buster should open the image file for you and display its contents. As with a real disc, you 
should see the word CD or DVD at the top-left of the tree on the left panel with a disc icon. Right-
click  on this  to  open the context  menu.  Select  MD5 checksum file >  Verify  this  image file  with 
existing MD5 checksum file. You will be prompted for the location of the .md5 file. Provide it.
Now ISO-Buster will recalculate the MD5 hash (checksum) of the existing image and tell you whether 
it matches the hash specified in the .md5 file or not. If it returns an error saying that “The checksum 
does NOT match!” instead of “The checksum matches with the image file” then either the .iso or the 
.cue file (or both) are probably corrupted and hence it is better to try re-creating the image from the 
original disc before going ahead with writing the image you have on hand.
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